Author Topic: Blackbody Radiation  (Read 15741 times)

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Blackbody Radiation
« on: April 06, 2010, 11:14:42 am »
Written by Fu-Kwun Hwang
Edited by Loo Kang WEE and Wolfgang Christian
Modified by myself

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #1 on: April 06, 2010, 11:24:57 am »
Blackbody Radiation

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #2 on: April 06, 2010, 11:25:37 am »
No work too prof  ???

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #3 on: April 06, 2010, 11:35:29 am »
Blackbody Radiation

Fu-Kwun Hwang

  • Administrator
  • Hero Member
  • *****
  • Posts: 3062
    • Enjoy the fun of physics with simulations
Re: Blackbody Radiation
« Reply #4 on: April 06, 2010, 12:14:23 pm »
There is another problem I found:

You did not save the xml file at the standard place.

Normally, you will select a workspace
For example: d:EJS_4.2.7workspace or any place like d:ejsworkspace
There are four subdirectory under the above workspace
config/export/output/source

We should put our xml source under source.

There is a sub-directory under source called users. That is the place for users to save his/her own xml files.
To avoid conflict between users (e.g. two users both create pendulum.xml ), so sub-directory are suggested.

For example: I save all my xml files under
 workspaceusers
tnufkh
where ntnu is the university where I did my work. fkh is for myself.
If there is other user at my university, then he/she is suggested to put file under workspaceusers
tnuxxx where xxx is his/her own identity.

I would suggest you save your xml file under workspaceusersrahmed or something else
However, it has to be at least under workspaceusers to work.
I believe you save your files at workspaceahmed , that is the reason why the uploaded jar file did not work. Because it might conflict with others.
Please move you directory ahmed under users (becomes users/ahmed or users/br/ahmed or ...)
and it should work.


ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #5 on: April 06, 2010, 07:37:52 pm »
Hi prof  :)
I delete ejs and download again and change path
From ejs consol to this D:/EJS_4.2.7/workspace/source/users/br/ahmed
So after i copy XML file of project and paste in user/br/ahmed
But when i run to open XML file in ejs said "the file selected must be under the source directory"
I don't know what mean it so I'm still now try understand what the problem in path

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #6 on: April 06, 2010, 08:04:01 pm »
 is not working again
« Last Edit: April 26, 2010, 08:51:33 pm by ahmedelshfie »

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #7 on: April 06, 2010, 08:35:28 pm »
I post again now i hope get succeed

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #8 on: April 06, 2010, 08:39:56 pm »
This is  just test

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #9 on: April 06, 2010, 08:47:02 pm »
This patm prof after i change i
Will send picture attach i renam user/br/ahmed

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #10 on: April 06, 2010, 09:06:22 pm »
This is test too  ;D

lookang

  • Hero Member
  • *****
  • Posts: 1772
  • http://weelookang.blogspot.com
    • lookang web
Re: Blackbody Radiation
« Reply #11 on: April 06, 2010, 09:39:01 pm »
for me
C:EasyJavaSimulationEJS_4.2_091119EJS_4.2workspacesourceuserssgeducationlookang


you need
brahmed

it will work

Fu-Kwun Hwang

  • Administrator
  • Hero Member
  • *****
  • Posts: 3062
    • Enjoy the fun of physics with simulations
Re: Blackbody Radiation
« Reply #12 on: April 06, 2010, 09:47:04 pm »
Hi prof  :)
I delete ejs and download again and change path
From ejs consol to this D:/EJS_4.2.7/workspace/source/users/br/ahmed
So after i copy XML file of project and paste in user/br/ahmed
But when i run to open XML file in ejs said "the file selected must be under the source directory"
I don't know what mean it so I'm still now try understand what the problem in path


You should not change the setting in the ejs console.
Set the workspace in ejs console back to D:/EJS_4.2.7/workspace/
And move D:EJS_4.2.7workspacesourceahmed to  D:EJS_4.2.7workspacesourceusersrahmed
If you do not have D:EJS_4.2.7workspacesourceusersr , you need to create it
then move D:EJS_4.2.7workspacesourceahmed to  D:EJS_4.2.7workspacesourceusersrahmed

If you change the workspace from D:/EJS_4.2.7/workspace/ to D:/EJS_4.2.7/workspace/source/users/br/ahmed/
Then EJS will try to find source from D:/EJS_4.2.7/workspace/ to D:/EJS_4.2.7/workspace/source/users/br/ahmed/sources/

You can change the directory of workspace to anywhere in your computer.
However, you need to have source/users/br/ahmed/ under the directory of your workspace.

I hope you can understand what I mean. ;)

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #13 on: April 06, 2010, 10:04:22 pm »
OK prof i do the same i change work speac and back workspace to what you say and
workspace in consol now is "D:/EJS_4.2.7/workspace/"
Workspace in source is"D:EJS_4.2.7workspacesourceusersrahmed"
So now i will test post simulation again

ahmedelshfie

  • Moderator
  • Hero Member
  • *****
  • Posts: 930
Re: Blackbody Radiation
« Reply #14 on: April 06, 2010, 10:13:41 pm »
Is the same prof
I do every thing i will send 2 pictures one or path in ejs consul and another
For path of users
When i do it and after convert to jar file he put jar file automatic in export
And when i come to upload simulation  Blackbody Radiation say this message"file ejs_Blackbody_Radiation_Spectrum.jar exists, file will be replaced!"
What mean it prof ???
Respect