The applet was created many years ago (more then 10 years) with JDK1.0.2
You might get error if you use latest jave to compile it (because java has severla major change over the year)

It should work fine if you use JDK1.0.2