unfortunately under software,  updates the curent java is the latest version.

guess i will find out why in later time :)

the earlier java applets like the vernier works in MAC OSX.

think i remember a check box to select java 1.5 or 1.6 compatible in EJS 4.0..... i go take a look again