There are two categories: Simulationsunder Physics simulation (current one) are created by JDK1.0.2 almost 10 years ago. Most browser should be able to support it. For those simulations under "Easy Java simuations (EJS)" are created with EJS and need latest java installed. You need JDK1.5 and above. You need to download and install latest[url=http://www.phy.ntnu.edu.tw/demolab/download/jre.exe] JRE [/url] (Java Run time Environment)